Google Apps: Mehr Probleme geht nicht

Ich hätte nie gedacht, dass ich das mal sagen würde, aber: Meine Güte, was ist Google für eine Frickelbude! Ich hätte nicht gedacht, dass ein Unternehmen, bei dem man im Einstellungstest remote Algorithmen entwickeln muss (bspw. Quicksort), massive Probleme mit grundlegenden Themen wie der Account-Verwaltung hat.

Aber von vorne: Derzeit arbeite ich an einer redundanten Maillösung mit Hilfe von "Google Apps". Die Idee ist, dass Googles Server als Fallback herhalten sollen, wenn der eigene Mailserver ausfällt.
Hierfür hatte ich im November einen Google Apps Free-Account erstellt und ein paar Domains mit diesem verbunden. Nachdem ich mitgekriegt hatte, dass man für die angestrebte Lösung einen Account pro Domain benötigt, entfernte ich die Domains aus dem Account und löschte den Account.

Hier begann nun das erste Problem: Man kann nicht sofort einen neuen Account anlegen - es dauert (laut Google) 5 Tage, bis der Account vollständig gelöscht wird. Also wartete ich, ich wartete, wartete, wartete... doch nichts geschah. Auch nach einem Monat konnte ich für die ganzen Domains (außer der Hauptdomain des letzten Google Apps Accounts) keinen neuen Account anlegen. Ständig erhielt ich die Nachricht:

"Diese Domain wurde registriert. Jetzt wird die Inhaberschaft überprüft. Falls es sich hier um eine unberechtigte Registrierung handelt, sollte sich der Administrator Ihrer Domain an den Google-Support wenden."

Also probierte ich folgendes: Ich fügte testweise eine der "klemmenden" Domains zum neuen Account hinzu, validierte sie und löschte sie wieder aus dem Account. Und siehe da: Plötzlich konnte ich für diese Domain einen Google Apps Account anlegen!

Soweit so gut. Dass ich hier über einen Monat Zeit mit sinnlos warten verschwendet hatte, sollte mich nicht weiter stören. Was mich aber störte, war folgendes: Beim Anlegen des 2ten neuen Accounts erhielt ich mittem im Erstellungsprozess einen 404-Fehler ("not found"). Ich war gearscht! Das Problem: Dieser 404-Fehler trat beim erstellen des ersten Nutzers des Google Apps Accounts auf. Mit anderen Worten: Es existiert derzeit ein Google Apps Account für Domain X in dem sich kein Nutzer befindet!

Was noch viel schlimmer ist: Wenn man auf der Login-Seite angibt, dass man das Passwort vergessen hat, kann man einen Passwort-Reset beantragen. Dieser erkennt sogar, dass kein Account existiert und leitet die Finalisierung der Erstellung ein. Und zack! Wieder ein 404-Fehler!

Es hat mir einfach gereicht, also dachte ich mir "kontaktiere ich halt den Support von Google". Im Ernst. Bei so einem riesigen Unternehmen gehe ich eigentlich davon aus, dass es ein Kinderspiel sein müsste, deren Support zu kontaktieren. Aber genau an dieser Stelle scheint Google massiv Geld einzusparen! Wenn man nach Kontaktmöglichkeiten sucht, wird man immer und immer wieder auf Selbsthilfeforen verwiesen. Suchen sie doch mal hier. Fragen sie doch mal dort. Es ist einfach nur traurig. Erst nach langem Suchen bin ich endlich auf ein richtiges Kontaktformular gestoßen.

Ob ich es überhaupt benutzen durfte? Ehrlich gesagt: Keine Ahnung. Aber auf jeden Fall wurde mir dort geholfen - halbwegs. Nach ein bissel hin und her, bei dem geprüft wurde, ob ich evtl. einfach nur zu dumm zum atmen bin, wurde ein Admin-Account angelegt. Die Zugangsdaten wollte man mir jedoch am Telefon mitteilen. Das klingelte dann auch irgendwann Mittags (übermittelt wurde eine brasilianische Telefonnummer). Rangegangen... Stille in der Leitung... ein paar Mal geguckt, ob sich jemand meldet... nichts... Toller Support!

Abschließend bin ich jetzt so vorgegangen: Ich wusste ja nun, dass ein Admin-Account erstellt wurde. Also habe ich nochmal den Passwort-Reset ausprobiert. Und siehe da: Es klappte! Ich erfuhr den Namen des Accounts, konnte das Passwort setzen, mich einloggen, einen neuen Account anlegen und den anderen Admin-Account löschen.

Wenn ich ehrlich sein soll... diese Erfahrung hat mein Vertrauen in die Fähigkeiten und Leistungen der Firma Google sehr verletzt. Ich war zwar schon immer Google-kritisch (aufgrund ihrer Datensammelpraktiken), aber nun habe ich obendrein auch Zweifel an ihrer Kompetenz.
Problematische Grüße, Kenny

1 Kommentar » Schreibe einen Kommentar

  1. Versuch mal, mit deaktivierten Cookies zu surfen, dann wird dein Vertrauen in den Rest des Internets sich ebenfalls verflüchtigen.

    Eine mögliche Fehlerquelle auf deinem Rechner könnte noch ein Virenscanner sein, der den HTTP-Traffic auf potenziellen Schadcode untersucht, und ungefragt deine Requests verbiegt. Bei nem Bekannten läuft so ein Gruselteil auf dem Firmenlaptop, das unterbricht stillschweigend und ungefragt gefühlte 50% der EXE-Downloads von sourceforge.net noch bevor das 1. Byte übertragen wird (vermutlich errechnet die "Heuristik" des Virenscanners anhand des Dateinamens sowie der aktuellen Mondphase, wie gefährlich der Download ist). Über HTTPS hat man glücklicherweise seine Ruhe und wird von dem Blödsinn verschont, an den heruntergeladenen Dateien hat der OnAccess-Virenscanner dann lustigerweise auch nix auszusetzen...

    Viel Erfolg noch mit deinem Projekt 🙂

Schreibe einen Kommentar

Um Ihnen beim weiteren Kommentieren auf dieser Webseite die erneute Eingabe Ihrer Daten zu ersparen, wird beim Absenden Ihres Kommentars ein Cookie an Ihren Browser gesendet und von diesem gespeichert. Mit dem Absenden eines Kommentars auf dieser Webseite stimmen Sie der Speicherung und Übertragung dieses Cookies explizit zu.

Pflichtfelder sind mit * markiert.